Project

General

Profile

Bug #512

Adding custom icon fails silently

Added by Kinrany Blackburn over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Target version:
Operating System:
Windows
Affected version:
Affected revision:

Description

Trying to add an icon, found here: http://www.campusrn.com/themes/cp_global_images/lg_social_bookmarks_module/favicons/reddit.png

After I choose the image and click "Open", dialog closes as if it was accepted, but it doesn't appear in the list of custom icons.

This is the only image I have this problem with, I was and am able to add other images.


Related issues

Duplicated by Bug #480: OSX El Capitan 10.11.4 - KeepassX 2.0.2: I can't add custom icon anymore Closed

Associated revisions

Revision 6e2de1cd
Added by Felix Geyer over 2 years ago

Display proper error message when reading an icon fails.

Refs #512

Revision 57ec5583
Added by Felix Geyer over 2 years ago

Detect image format solely on content.

Otherwise reading fails if the file extension is wrong.

Closes #512

History

#1 Updated by Felix Geyer over 2 years ago

  • Status changed from New to Closed

#2 Updated by Florian Geyer over 2 years ago

  • Related to Bug #480: OSX El Capitan 10.11.4 - KeepassX 2.0.2: I can't add custom icon anymore added

#3 Updated by Felix Geyer over 2 years ago

  • Target version set to 2.0.3

#4 Updated by Felix Geyer over 2 years ago

  • Related to deleted (Bug #480: OSX El Capitan 10.11.4 - KeepassX 2.0.2: I can't add custom icon anymore)

#5 Updated by Felix Geyer over 2 years ago

  • Duplicated by Bug #480: OSX El Capitan 10.11.4 - KeepassX 2.0.2: I can't add custom icon anymore added

Also available in: Atom PDF