Project

General

Profile

Bug #51

Similar-looking letters in displayed passwords are easily confused

Added by Saj G over 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
Operating System:
Mac OS
Affected version:
Affected revision:

Description

I have attached a screenshot to illustrate the problem. Symbols like alphabetic uppercase Oscar (O) are too easily confused with numeric zero (0). Similarly, alphabetic lowercase Lima (l) is easily confused with alphabetic uppercase India (I) and the pipe symbol (|).

Ambiguous symbols are a problem for randomly generated passwords that cannot be copy-pasted for whatever reason. (Perhaps I need to manually punch the password in on a device that is not running KeePass.)

One potential solution to this problem would be to display the password using a fixed-width programmer's typeface, like Monaco, which is designed to avoid these ambiguities. The remainder of the UI should remain unchanged.

Screen Shot 2012-11-10 at 16.37.43 .png (70.7 KB) Saj G, 11/10/2012 06:55 AM

фотография.PNG - 1Password screen (126 KB) Alex S, 03/30/2013 09:12 AM


Related issues

Duplicated by Bug #183: Passwords made visible are ambiguous when reading due to the font Closed 04/22/2014

Associated revisions

Revision 4ded95a0
Added by Felix Geyer over 3 years ago

Add PasswordEdit class.

It displays passwords in monospace which closes #51

History

#1 Updated by Alex S about 4 years ago

1Password for iPhone uses fixed type font + color coding for digits. I think it's cool feature for usability.

#2 Updated by Daniel K. over 3 years ago

One potential solution to this problem would be to display the password using a fixed-width programmer's typeface, like Monaco, which is designed to avoid these ambiguities. The remainder of the UI should remain unchanged.

I am also in favor of the monospaced font for the password field.

#3 Updated by Felix Geyer over 3 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

#4 Updated by Felix Geyer over 3 years ago

  • Target version set to 2.0 Alpha 6

#5 Updated by Randy Hudson over 2 years ago

I'm using alpha 6 but I still don't see a monospace font being used on OS X

#6 Updated by Oli Ver about 2 years ago

I can confirm Randy Hudson's statement. I created a forge with a small font change some time ago. I started a pull request on github. Please have a look and consider it: https://github.com/keepassx/keepassx/pull/83

#7 Updated by Oli Ver about 2 years ago

*fork not forge :-)

#8 Updated by Felix Geyer about 2 years ago

Oli Ver wrote:

I can confirm Randy Hudson's statement. I created a forge with a small font change some time ago. I started a pull request on github. Please have a look and consider it: https://github.com/keepassx/keepassx/pull/83

Have you tested the current master branch if this is still an issue?
Commit 87468b648bbefc373990cfd9e1fc3cb6214e90c6 happened after Alpha 6.

Also available in: Atom PDF