Project

General

Profile

Bug #501

Unable to open database (invalid key)

Added by cabrones hola over 2 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
Operating System:
Linux
Affected version:
Affected revision:

Description

Hi,

I have lost for second time all my passwords using this software.

1 time: It was a year ago after using this software for 2 years suddenly I was unable to open the dabatase cause It said "invalid key or corrupted database". I tried everything even cracking and I was unable, so I learnt the lesson have BACKUPS.

2 time:I started using again keepassx a month ago but now 2.x version (Fedora 23) and:

a)Make a initial db and send it to my email
b)start using it and add it to a remote git repo
c)Using it for a month, openning saving passwords and commiting new changes to remote
d)Yesterday suddenly I was unable to open the database "invalid key or corrupted database".
e)I have tried without luck open the initial file sent to my email and in all the git commits to open the databases:
*Compile from repo
*From other machine (linux)
keepass2 =======
*Install from other machine (windows xp)
*From VM (windows xp)
*From portable (windows xp)
*From portable (vm windows xp)
*From portable (vm windows xp)
f)I have tried the same password in a new database and I confirm I can open it with any of the above solutions.

I know my password cause I have written it down, I haven't changed it and I have been using this key without issue for the last month.
I have read that the file permissions needs to be 600 I have tried that without luck.

I am feeling really dissapointed. :(

History

#1 Updated by cabrones hola over 2 years ago

Hi guys!!!!

It turned out that I was written it down wrong and every time I was using it I was blind mistyping a character. ¿?¿?¿?

Now I can open my files!!!

Yeeeha!

I was feeling really depressed and paranoid. :|

So you can close it!!

Cheers and thanks for your work!.

#2 Updated by Florian Geyer over 2 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF