Project

General

Profile

Bug #454

Global auto-type shortcut, when KeePassX is locked, does not give unlock option

Added by mrK * almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Operating System:
Linux
Affected version:
Affected revision:

Description

When KeePassX 2.0.2 is locked and the global auto-type shortcut is used on any web page, KeePassX gives out an info window (see attachment) saying

Couldn't find an entry that matches the window title: [web page title].

This happens irrespective of whether the corresponding auto-type keyword is present or not.

Steps to reproduce

  1. Open KeePassX;
  2. Log in to the password database;
  3. Lock the database manually (click on the lock icon) or wait for it to be locked automatically (if enabled);
  4. Open any login page in a web browser;
  5. Press the auto-type global short cut.

Actual result - Info window pops up saying "Couldn't find an entry that matches the window title: [web page title]".
Expected result - Password prompt to unlock KeePassX.

System info

Installed from getdeb - KeePassX v2.0.2
Revision - 3679b2170142c14362fa75e990ef85b80b1b1b46
Using Qt 4.8.6 and libgcrypt 1.6.1
OS - Linux Mint 17.2 x64 Mate (marco window manager v1.10.2)

Auto-Type - KeePassX_001.png - Info window - Couldn't find an entry... (13.1 KB) mrK *, 03/10/2016 12:21 PM


Related issues

Duplicates Bug #197: auto-type requires workspace to be unlocked. should not New

History

#1 Updated by piyush garg over 2 years ago

Just updated to ubuntu 16.04 and this issue cropped up to me it seems the old version of keepassx has been updated in recent release causing the same issue to me as well.
The unlocking of database is not working instead it shows the "Couldn't find an entry..."

#2 Updated by Mr DNA over 2 years ago

piyush garg wrote:

Just updated to ubuntu 16.04 and this issue cropped up to me it seems the old version of keepassx has been updated in recent release causing the same issue to me as well.
The unlocking of database is not working instead it shows the "Couldn't find an entry..."

Same issue here. Upgrading from Ubuntu 15.10 to 16.04 automatically updated KeePassX to 2.0.2. I almost wonder if this is truly a bug or if it was by design. Regardless, it completely breaks functionality for me. I uninstalled KeePassX 2.0.2 then manually installed 0.4.3 from the terminal. All is well again.

#3 Updated by Nathan Schulte over 2 years ago

I'm pretty sure this is a duplicate of https://www.keepassx.org/dev/issues/197

#4 Updated by Florian Geyer over 2 years ago

  • Status changed from New to Closed

Closing as duplicate of #197.

#5 Updated by Felix Geyer over 2 years ago

  • Duplicates Bug #197: auto-type requires workspace to be unlocked. should not added

Also available in: Atom PDF