Project

General

Profile

Bug #359

[v2.0 beta-2] Global Hotkey Auto-Type broken on multi-desktop KDE environment

Added by Tormen T. over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
Operating System:
Linux
Affected version:
Affected revision:

Description

Hi,

I started testing v2 and having an issue with Global Hotkey and KDE multiple desktops :
If keepassX is open on desktop 1, and app on desktop 4 is active and the global hotkey is pressed, then the "Select entry to Auto-Type" window appears on the desktop 1 (and not 4, like it was the case with keepassX v1). This change of desktop is not nice.

But the real problem comes when selecting one auto-type entry:

Neither the window on desktop 4 seems to receive anything and also no window on desktop 1... so basically auto-type does not work in this case.

Please let me know if there is anything else I can provide.

Tormen

Associated revisions

Revision b02ec98e
Added by Felix Geyer over 1 year ago

Show AutoTypeSelectDialog on the active desktop.

This wasn't always the case on X11 with virtual desktops.

Closes #359

History

#1 Updated by System Schraube over 1 year ago

Hi,

I can confirm this issue, since I have exact the same problem under Debian Jessie with KDE.

#2 Updated by Felix Geyer over 1 year ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

#3 Updated by Felix Geyer over 1 year ago

  • Target version set to 2.0

Also available in: Atom PDF