Project

General

Profile

Feature #329

Close to tray

Added by Martin von Gagern over 1 year ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:

Description

When using the system tray, then the main window seems like a window opened in addition to the tray icon. Therefore, closing said window doesn't feel like it should terminate the application. Instead, closing the main window should have the same effect as minimizing it: reduce the application to tray only. Or perhaps minimize should then work to minimize to task bar, and close would reduce to tray. I know I have audacious configured the same way, and this feels very natural to me.

If you, for some reason, decide against this, then I'd very much welcome a shortcut to minimize the window. Since Alt+F4 terminates the app and Ctrl+W closes the database, something else is needed to allow for quick keyboard interaction.


Related issues

Duplicated by Bug #343: Reduce to systray when close Closed 09/11/2015

Associated revisions

Revision bb38be40
Added by Felix Geyer over 1 year ago

Enable Ctrl+M shortcut to minimize window on all platforms.

Closes #329

History

#1 Updated by Felix Geyer over 1 year ago

  • Duplicated by Bug #343: Reduce to systray when close added

#2 Updated by Felix Geyer over 1 year ago

Minimizing the application to the tray icon when you close it makes no sense to me.
You want to get the window out of your way, that's what the minimize action is there for.

Having a shortcut to minimize the application is a fair point though.
I'll add Ctrl+M (already existed on OS X only).

#3 Updated by Felix Geyer over 1 year ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

#4 Updated by Felix Geyer over 1 year ago

  • Target version set to 2.0

#5 Updated by Dan LaManna over 1 year ago

For what it's worth, this seems to be a regression (as mentioned in #343), and completely breaks the workflow of window managers that don't have a minimize function (i.e. most tiling window managers).

I know everything breaks someone's workflow. However, it's commonplace to have applications close to the system tray (at least as an option) especially when they serve a purpose with global keybinds (autotype in this case).

Since 2 people have reported this, and I'm also experiencing frustration - would a patch be welcome if I were to make it a configurable option?

#6 Updated by Connor Glosser about 1 year ago

I'd also like to voice my desire for a "close to tray" option as, like Dan LaManna said, I don't have a minimize function in my tiling window manager.

#7 Updated by F H about 2 months ago

I'd like to echo Dan LaManna's and Connor Glosser's request for a "close to the system tray" feature. I happily used KeePassX v1.* in this manner, and for the last 2 years or so I have tried to get used to the fact that this is no longer possible in v2.*, but to no avail. :)

IMHO, this should become a config option in KeePassX's Tools > Settings menu. There already is an option to "Hide window to system tray when minimized", which could be complemented by a "Hide window to system tray when closed" option.

#8 Updated by F H about 2 months ago

Duh, hadn't realized this issue is already closed and was addressed through the introduction of the Ctrl+M shortcut... I guess I'll give it another 2 years trying to learn an application-specific shortcut then ;)

#9 Updated by Nathan Schulte about 2 months ago

On systems (such as those using tiling window managers, like i3) where there is no minimize shortcut, the ability to selectively enable a "close to system tray" (or "hide to system tray when closed") feature is very useful.

I think an application should not conflate "Close" with "Exit" (or "Quit", if you like, though that seems to be a "middle ground" of the two, to me); just because a user wishes to close the (main...) window, doesn't necessarily mean they wish to the application to exit!

Steam, a very popular social video gaming (and more...) platform, takes the stance I propose. As mentioned, KeePassX v1 supported this stance. I can find other examples if needed, too.

Also available in: Atom PDF