Project

General

Profile

Bug #326

KeepassX 2.0 Beta 1 - Once minimized can not restore

Added by Joao Cabral about 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
Operating System:
Linux
Affected version:
Affected revision:

Description

If the option to "Hide Windows to system tray when minimized" is active
and you minimize the window, you can no longer restore it.

If "Show a system tray icon" is disabled.... no way of recovering....
If that same option is enabled, right clicking on it and selecting "toggle window" does nothing

If Hide Windows to system tray when minimized is disabled
If "Show a system tray icon" is disabled.... it works as designed, it will minimize to the task bar and it can be restored
If "Show a system tray icon" is enabled, and the application is minimized, right clicking on it and selecting "toggle window" does nothing
if the application is NOT minimized, it toggle the application from visible to not visible and vice versa


Related issues

Duplicated by Bug #376: [Mac] Cannot restore minimized window without system tray Closed 11/19/2015

Associated revisions

Revision 58ed99d5
Added by Felix Geyer almost 2 years ago

OS X: Restore main window when clicking on the docker icon.

Apparently this worked previously. Maybe a regression in Qt?

Refs #326

Revision e98c30f6
Added by Felix Geyer almost 2 years ago

Disable systray on OS X.

It's not useful on that platform.

Refs #326

History

#1 Updated by Branko Čibej almost 2 years ago

Confirmed; with 2.0 Beta 2 on OSX 10.11.

#2 Updated by Felix Geyer almost 2 years ago

Could you please test if the latest build from the 2.0 branch fixes this problem?
Download: https://www.keepassx.org/snapshots/KeePassX-1.9.92-20150930.dmg

#3 Updated by Branko Čibej almost 2 years ago

No, it does not.

  • When the window is minimized to the tray, clicking the icon does change focus, but the window isn't restored.
  • When I click on the system tray icon, the window is restored, but does not get focus; I have to click on it.

#4 Updated by Felix Geyer almost 2 years ago

I know why I didn't want to implement tray icons in the first place.
This window hiding business is such a subtly different mess on each platform.

So ... patches welcome.
I might end up disabling the tray icon feature on OS X for the 2.0 release.

#6 Updated by Joseph Thompson almost 2 years ago

I can't exactly reproduce this on Xubuntu 15.04. The tray icon doesn't always appear, but when it does, minimizing to it works as intended.

Tray icons seem like a can of worms. Why not strip out the entire feature?

#7 Updated by Felix Geyer almost 2 years ago

@Branko and other OS X users:
What would you actually expect from a tray icon?
Hiding the window to tray seems rather inconvenient since you need two clicks (tray icon, toggle window) to restore it.
The docker already provides a consistent location where you can put the KeePassX window to the front.

#8 Updated by Branko Čibej almost 2 years ago

I quite frankly don't see any use for the tray icon on OSX. I was quite happy with the behaviour of the alpha releases, where clicking on the KeePassX icon in the docker consistently DTRT.

With the current 2.0 betas I only turned on the icon because it's the only way to restore the window once it's minimised ... a step back, in my opinion.

Of course there's a lot that could be done with keeping the app visible only as a tray icon on OSX; but that would be a lot of work for not much gain, and not very portable. Possibly something someone can play with in future releases, but for 2.0, I suggest just ripping out the tray icon.

#9 Updated by Felix Geyer almost 2 years ago

Branko Čibej wrote:

I quite frankly don't see any use for the tray icon on OSX. I was quite happy with the behaviour of the alpha releases, where clicking on the KeePassX icon in the docker consistently DTRT.

With the current 2.0 betas I only turned on the icon because it's the only way to restore the window once it's minimised ... a step back, in my opinion.

Of course there's a lot that could be done with keeping the app visible only as a tray icon on OSX; but that would be a lot of work for not much gain, and not very portable. Possibly something someone can play with in future releases, but for 2.0, I suggest just ripping out the tray icon.

Thanks for the feedback.

I've disabled the systray on OS X and (hopfeully) fixed the bug that clicking on the dock icon doesn't restore the window.

Another snapshot for testing:
https://www.keepassx.org/snapshots/KeePassX-1.9.92-20151010.dmg

#10 Updated by Branko Čibej almost 2 years ago

Perfect! This fixes the window-restore bug. Thanks!

#11 Updated by Janek Bevendorff almost 2 years ago

I can confirm similar issues on KDE/Plasma5 using the latest snapshot from master.
Restoring from tray works fine when the window was minimized using the minimize button in the window title bar. But when I click the tray icon while to window is visible to minimize it, I can't restore it anymore.
Usually I don't do that which is why I haven't noticed the bug earlier, but it's still a bug that should be fixed I think. Once the window has been minimized using the system tray, the only way to get the window back is to right click the icon, click "Quit" and then restart.

#12 Updated by Felix Geyer almost 2 years ago

Janek Bevendorff wrote:

I can confirm similar issues on KDE/Plasma5 using the latest snapshot from master.

Which Qt5 version are you using?

#13 Updated by Janek Bevendorff almost 2 years ago

Qt 5.5.1

#14 Updated by Felix Geyer almost 2 years ago

I can't reproduce this.
Which KeePassX revision are you using (check the about dialog)?

#15 Updated by Felix Geyer almost 2 years ago

  • Target version set to 2.0

Anyway it's a different bug.
If it's still a problem with the latest master branch, please open a new bug.

#16 Updated by Felix Geyer almost 2 years ago

  • Status changed from New to Closed

#17 Updated by Felix Geyer almost 2 years ago

  • Duplicated by Bug #376: [Mac] Cannot restore minimized window without system tray added

#18 Updated by Piotr Dobrogost over 1 year ago

Felix Geyer wrote:

Anyway it's a different bug.
If it's still a problem with the latest master branch, please open a new bug.

Could you please tell us why you think "it's a different bug"? The bug was raised for Linux and comment #11 confirms the bug is present on KDE/Plasma5 thus Linux.

I also confirm this issue is present on KDE Plasma 5.5.5, Qt 5.6.0 on Fedora 24, KeePassX 2.0 rev. 24275d8dc40b3b048a4dde4dca9ceb63a19be8af

#19 Updated by Janek Bevendorff over 1 year ago

I can confirm that this issue still exists, using Plasma 5.6.0.
And I don't think either that this is a different issue. It's exactly what the initial reported described. It is possible to restore KeePassX from the tray if I only minimize it using the minimize button on the window title bar. But If I minimize it any other way, the window does not appear again.

If you minimize it and then click the tray button for restoring it, but the window does not show up, I also have to make sure to click it again to minimize it. Otherwise when I restart KeePassX the window will not show up either (since it will start in this weird invisible mode). If I click it again, however, it will start minimized and I can restore the window as expected.

Also available in: Atom PDF