Project

General

Profile

Bug #309

Crash when locking with search UI open

Added by bob loblaw over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
High
Assignee:
-
Target version:
Operating System:
Mac OS
Affected version:
Affected revision:

Description

Enjoying the new beta since it fixed one of my biggest annoyances with KeepassX (bug #275, close database when locking).

Unfortunately it seems to have introduced a nasty new bug for me. Running on OSX 10.10.4.

Steps:

1) Unlock database
2) Open search UI (cmd+F on Mac). Type something or don't.
3) Lock the database. (Including automatic lock after time set by user.)
4) KeepassX has crashed ("KeepassX quit unexpectedly.")
5) Reopen KeepassX and meet your new popup friend: "The database you are trying to open is locked by another instance of KeePassX." He won't go away until you remove the ".[database].lock" file.

Happens every time. Can someone please see if they can reproduce this? On my platform and/or otherwise.

keepass2b1_crash.txt Magnifier (49.5 KB) Jürgen Stamminger, 07/20/2015 06:55 PM


Related issues

Duplicated by Bug #314: Frequent crashes of Beta1 on OSX El Capitan Closed 07/25/2015
Duplicated by Bug #318: repeated crashes on OSX Yosemite & El Capitan since moving from 2.0alpha6 -> 2.0beta1 Closed 07/29/2015
Duplicated by Bug #330: Crash after wait a while on Find in Mac OS X Closed 08/28/2015
Duplicated by Bug #332: Crashes on autolock after searching Closed 08/30/2015
Duplicated by Bug #335: Locking the Database during search crashes with EXC_BAD_ACCESS Closed 09/01/2015
Duplicated by Bug #336: OSX 10.10.5 Crash on auto lock Closed 09/02/2015

Associated revisions

Revision 41a7c969
Added by Florian Geyer over 1 year ago

Close search before locking database and add additional check on current group.

Closes #309.

History

#1 Updated by bob loblaw over 1 year ago

Also: doesn't crash if you open the search UI, then close it (hit escape).

#2 Updated by Felix Geyer over 1 year ago

  • Target version set to 2.0 Beta 2
  • Priority changed from Normal to High

Thanks for reporting. I can reproduce this on Linux.
Will look into it.

The lock file handling seems also a bit broken on OS X but that's a separate issue.

#3 Updated by Jürgen Stamminger over 1 year ago

I can reproduce it with OS X 10.10.4.
Right after the DB is locked, an error report from OS X shows up (see attached error file)

#4 Updated by Florian Geyer over 1 year ago

  • % Done changed from 0 to 100
  • Status changed from New to Closed

#5 Updated by Felix Geyer over 1 year ago

  • Duplicated by Bug #314: Frequent crashes of Beta1 on OSX El Capitan added

#6 Updated by bob loblaw over 1 year ago

Are there plans to put out a new beta build with this fix some time soon?

#7 Updated by Florian Geyer over 1 year ago

  • Duplicated by Bug #318: repeated crashes on OSX Yosemite & El Capitan since moving from 2.0alpha6 -> 2.0beta1 added

#8 Updated by Florian Geyer over 1 year ago

  • Duplicated by Bug #330: Crash after wait a while on Find in Mac OS X added

#9 Updated by Florian Geyer over 1 year ago

  • Duplicated by Bug #332: Crashes on autolock after searching added

#10 Updated by Florian Geyer over 1 year ago

  • Duplicated by Bug #335: Locking the Database during search crashes with EXC_BAD_ACCESS added

#11 Updated by Felix Geyer over 1 year ago

  • Duplicated by Bug #336: OSX 10.10.5 Crash on auto lock added

Also available in: Atom PDF